Elevated latencies for our Stream Controller service
Incident Report for PubNub
Postmortem

From 10 - 10:21 PM UTC customers experienced elevated latencies for our Stream Controller and Presence services. This was particularly noticeable in our Tokyo PoP. This was caused by increased load hitting a single data shard, causing it to become overwhelmed. We are reconfiguring our databases so that load will be spread more evenly to decrease the likelihood of a hot shard in the future.

Posted over 1 year ago. Jul 12, 2018 - 21:41 UTC

Resolved
Customers, particularly in our Tokyo PoP, may have experienced higher-than-average latencies for our Stream Controller and Presence services. There were no errors caused by this and latencies have returned to normal. The issue is resolved but we will continue to monitor.
Posted over 1 year ago. Jul 11, 2018 - 22:45 UTC
This incident affected: Realtime Network (Stream Controller Service).