Potential for some missed messages for subscribers in IAD

Incident Report for PubNub

Resolved

There have been no further issues for the past 45 minutes. We are resolving this issue, and we will follow up with a post-mortem soon.
Posted Oct 17, 2025 - 08:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2025 - 07:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 17, 2025 - 06:48 UTC

Investigating

We are currently investigating an incident that could lead to some missed messages by subscribers in the IAD region. All messages are being received and persisted, and can be retrieved from the Storage service.

This incident started around 22:07 UTC (03:00 PDT) on 16th Oct 2025. We suspect a moderate impact. Please report any impact related to this incident to support@pubnub.com with any details that you can provide.
Posted Oct 17, 2025 - 06:42 UTC
This incident affected: Realtime Network (Publish/Subscribe Service) and Points of Presence (North America Points of Presence).