Presence service missing timeout events
Incident Report for PubNub
Resolved
All services and systems have been operating normally for two hours. This incident is resolved.
Posted Feb 01, 2020 - 23:52 UTC
Monitoring
The Presence timeout backlog has completed processing, and all services are stable and operating normally. We will continue to monitor.
Posted Feb 01, 2020 - 21:25 UTC
Investigating
Timeout events in the PubNub Presence service are failing to process successfully, resulting in an inaccurate state (i.e. some devices/users still showing as active in a channel when they had actually disconnected). The source of the issue has been identified and a mitigation has been implemented. The service is currently processing the backlog of disconnect events.
Posted Feb 01, 2020 - 21:02 UTC
This incident affected: Realtime Network (Presence Service).