Presence, Subscribe and Publish service experienced elevated latencies and errors in US East region
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution 

At 10:20 UTC on 2022-01-21, we observed elevated latencies and errors for Subscribe, Publish, and Presence service in the US East region. This issue occurred during the migration of another service. The issue was quickly diagnosed and resolved, with services returning to normal at approximately 10:30 UTC. 

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring we have established new runbooks items and necessary monitoring to alert our on-call staff.

Posted Feb 07, 2022 - 16:59 UTC

Resolved
Presence, Subscribe and Publish services were impacted briefly by maintenance work related to the admin portal. As a result, service was degraded in US East PoP from approximately 10:21 UTC to 10:29 UTC.

We apologize for the impact this may have had on your service. Please reach out to us by contacting PubNub Support (support@pubnub.com) if you wish to discuss the impact on your service.

This issue is resolved, and we will follow up with a post-mortem soon.
Posted Jan 21, 2022 - 11:37 UTC
This incident affected: Realtime Network (Publish/Subscribe Service, Presence Service) and Points of Presence (North America Points of Presence).