Region-Wide Service Issues in Europe
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution

Due to a data center failure of one of our cloud infrastructure providers, we experienced higher than usual latencies across all of our services in our Europe point-of-presence from 12:06 PM to 12:55 PM UTC. We routed traffic around these issues to minimize latency and impact while the provider rectified its issues. Once the infrastructure was stable, we were able to return traffic to its normal flow.

Posted Jul 17, 2021 - 05:59 UTC

Resolved
The incident has not resurfaced since 12:56 UTC. We are resolving this issue, and we will follow up with a post-mortem soon.

We apologize for the impact this may have had on your service. Please reach out to us by contacting PubNub Support (support@pubnub.com) if you wish to discuss the impact on your service.
Posted Jul 13, 2021 - 14:17 UTC
Monitoring
A failure in an underlying cloud provider was causing elevated errors and latency in our European point-of-presence. We routed traffic around the errors while the issues persisted. The issues have been corrected, and we are currently monitoring traffic to ensure there are no other issues.
Posted Jul 13, 2021 - 13:33 UTC
Update
We are continuing to investigate this issue.
Posted Jul 13, 2021 - 13:16 UTC
Investigating
We are currently investigating region-wide issues in our Europe point-of-presence.
Posted Jul 13, 2021 - 13:03 UTC
This incident affected: Realtime Network (Publish/Subscribe Service, Storage and Playback Service, Stream Controller Service, Presence Service, Access Manager Service, Realtime Analytics Service, DNS Service, Mobile Push Gateway, MQTT Gateway, Objects Service), Functions (Functions Service, Vault, Key Value store, Scheduler Service), and Points of Presence (European Points of Presence).