Subscribe is experiencing elevated latencies in the EU PoP
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution 

On Tuesday, March 21, 2023 at 09:08 UTC, we observed errors, timeouts, and delays in message delivery in our EU Central PoP. We rolled back the responsible configuration changes, and the issue was resolved at 09:38 UTC. This issue occurred due to a configuration change that allowed our subscribe service to use the existing resources better. Unfortunately, this caused us to hit a limit in open connection counts, leading to delays in creating new connections.  This, in turn, led to delayed subscribe call connections and message delivery. This was the same issue that occurred on March 16th. Unfortunately, it is particularly difficult to measure the customer impact of the subscribe API.

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring in the future, there is a metric we can use to approximate customer impact that we will monitor closely going forward, including during any further configuration changes.

Posted Mar 27, 2023 - 18:15 UTC

Resolved
Between 12:25 - 14:45 UTC, Customers using Subscribe service in our EU Central PoP may have experienced some errors, timeouts, and delays in message delivery.
Posted Mar 22, 2023 - 15:43 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 22, 2023 - 15:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2023 - 15:22 UTC
Investigating
Customers using Subscribe service in our EU Central PoP may be experiencing errors, timeouts, and delays in message delivery
Posted Mar 22, 2023 - 15:15 UTC
This incident affected: Realtime Network (Publish/Subscribe Service).