Increased latencies in Europe
Incident Report for PubNub
Postmortem

Incident Summary

For several hours on January 5 2018, clients experienced elevated latencies for subscribe calls from Europe. Other types of requests and other regions were unaffected.

Root Cause

Due to a DNS configuration issue made during some standard maintenance we were performing, we experienced an unexpectedly large increase in traffic in Europe. Some of our data centers, mainly in APAC, were directing traffic to Europe which lead to the excess load. We were able to add more capacity and the latencies returned to normal. The DNS configuration problem was also fixed and load dropped to normal levels. We will be making a number of changes to our change management process around DNS to ensure that this issue or similar is not repeated again.

Posted Jan 11, 2018 - 10:35 UTC

Resolved
After careful monitoring we see no further issues and are closing the incident.
Posted Jan 05, 2018 - 23:45 UTC
Monitoring
We have identified the problem and put in a fix and latencies have dropped to normal levels. We are going to continue to monitor to ensure that there are no further problems.
Posted Jan 05, 2018 - 19:25 UTC
Update
We are continuing to investigate the situation with urgency. We are tracing down a couple of potential leads. We will continue to update this page as more information/progress is available.
Posted Jan 05, 2018 - 18:46 UTC
Investigating
We are looking into a problem of higher than usual latencies in Europe. We are investigating and will update as we find things.
Posted Jan 05, 2018 - 17:49 UTC