Delays in Presence, Push, and Storage in our Europe PoP
Incident Report for PubNub
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 11:04 UTC
Monitoring
Our failover measures have worked and there are no longer delays in Push deliveries, messages being saved to the storage, or lost join/leave events. Our system is recovered but we will continue to monitor until our provider has resolved the issue on their end.
Posted Nov 12, 2019 - 10:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2019 - 09:58 UTC
Update
Our failover measures have worked and there are no longer delays in Push deliveries or messages being saved to storage. Our system is largely recovered but it is still possible that a small number of customers not using presence heartbeats could see devices going offline.
Posted Nov 12, 2019 - 09:49 UTC
Update
We have routed around the failures and service is recovering but there still may be some delays.
Posted Nov 12, 2019 - 09:32 UTC
Identified
Due to an incident with our provider, customers in Europe may be seeing delays in messages being written to storage or push messages being sent. Customers not using presence heartbeats may also be seeing their devices going offline.
Posted Nov 12, 2019 - 09:29 UTC
This incident affected: Realtime Network (Storage and Playback Service, Presence Service, Mobile Push Gateway).