Some Services Across US East Are Suffering From Partial Outage
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution 

At 19:20 UTC on Tuesday June 13th, 2023  we observed increased error rates and latency for our Authorization services at our US East facility.  In response, we redirected authorization services from US East to US West, and the issue was mitigated at 20:59 UTC on Tuesday June 13th, 2023. During this time, we identified the root cause of the issue was due to a third-party service incident. After confirming the third-party service incident was resolved, we rerouted the Authorization traffic back to US East at 22:58 UTC on Tuesday, June 13th 2023. 

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring in the future we are developing a comprehensive failover plan to more quickly move services from one region to other regions..  In the next few weeks we will be implementing new processes to allow mitigation of regional service issues.

Posted Jun 20, 2023 - 13:32 UTC

Resolved
This incident has been resolved, all services fully restored.
Posted Jun 13, 2023 - 22:58 UTC
Monitoring
We are continuing to monitor the changes that we have implemented to mitigate this incident.
Posted Jun 13, 2023 - 20:59 UTC
Update
We have taken steps to mitigate this issue. Error rates and latency have be reduced.
Posted Jun 13, 2023 - 20:28 UTC
Identified
This is particularly effecting Authorization and downstream Objects.
Posted Jun 13, 2023 - 19:30 UTC
This incident affected: Points of Presence (North America Points of Presence) and Realtime Network (Access Manager Service, Objects Service).