Delayed Push Notifications in Frankfurt PoP
Incident Report for PubNub
Postmortem

At 18:53 UTC on June 7, 2024, we observed excessively latent deliveries of mobile push messages in our Frankfurt point-of-presence. We discovered that a previously undetected bug was being triggered by malformed messages being sent to the service. We increased the resources available to that service, which allowed the system to catch up and deliveries were being made normally. The issue was declared resolved at 19:59 UTC.

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring in the future we are leaving the system running in the new configuration. We will also increase monitoring for this area, and will be modifying the push notification service to rectify the bug that triggered the scenario originally.

Posted Jun 13, 2024 - 00:03 UTC

Resolved
This incident has been resolved, and mobile push notifications are being delivered normally. We will follow up with a root cause analysis.
Posted Jun 07, 2024 - 20:35 UTC
Monitoring
We have processed all push messages in our backlog and stabilized the system in Frankfurt. We are monitoring the system to ensure no further issues.
Posted Jun 07, 2024 - 20:07 UTC
Update
We are still experiencing some delayed delivery of push messages in our Frankfurt point-of-presence. We continue to investigate the issue.
Posted Jun 07, 2024 - 19:49 UTC
Investigating
We have discovered an issue where push notifications were not being delivered in our Frankfurt point-of-presence. Those notifications were then delivered about twenty minutes late. We are investigating the issue.
Posted Jun 07, 2024 - 19:25 UTC
This incident affected: Realtime Network (Mobile Push Gateway).