Proactive Reconfiguration of PubNub Services
Incident Report for PubNub
Postmortem

We received a notification from an infrastructure provider that they were having issues that could affect our US-East Point of Presence. On that recommendation, we shifted our infrastructure to avoid any potential problems. We posted this incident in advance of shifting, in order to keep our customers informed of any issues that might arise. In the end, we were able to make the changes (and revert them back once the provider was stable again) without any disruption to PubNub services. As always, please contact PubNub Support with any questions about this (or other) concerns or issues.

Posted Oct 03, 2023 - 20:26 UTC

Resolved
We've had no customer impact from this configuration change, and are closing this incident. As always, contact PubNub support with any questions.
Posted Sep 28, 2023 - 22:42 UTC
Monitoring
We have completed our changes, with no customer impact reported. We will continue to monitor the situation closely.
Posted Sep 28, 2023 - 22:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2023 - 21:19 UTC
Investigating
We are proactively reconfiguring our services, based on advice from an infrastructure provider that is experiencing issues in our US-East point-of-presence. There is no customer impact at this time, and we will update this page if we see any impact during this process. Please contact PubNub support if you experience any issues.
Posted Sep 28, 2023 - 21:18 UTC
This incident affected: Realtime Network (Publish/Subscribe Service, Storage and Playback Service, Stream Controller Service, Presence Service, Access Manager Service, Realtime Analytics Service, DNS Service, Mobile Push Gateway, MQTT Gateway, Objects Service), Website and Portals (Website, Administration Portal, SDK Documentation, PubNub Support Portal), Functions (Functions Service, Vault, Key Value store, Scheduler Service), and Points of Presence (North America Points of Presence).