Elevated rate of latency and timeouts in US East Point of Presence (POP)
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution 

On April 2, 2023 at 15:34 UTC we observed an increased rate of timeouts and errors in our services for Presence, Push, History, Subscribe, and Auth Services in our US East Point of Presence. We identified the issue was related to repair work being performed on this PoP by one of our third party vendors. After identifying the issue, we rerouted traffic from US East to US West and moved the incident to Monitoring status since improvement was observed. Once we received an update from our third-party vendor that the repair work was complete, we routed traffic back to our US East PoP, and the issue was resolved at 17:13 UTC.

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring in the future we will implement more granular monitoring and alerting for early warning of such issues to the affected infrastructure.

Posted Apr 05, 2023 - 00:34 UTC

Resolved
This incident has been resolved and we will follow up with a post-mortem soon.

We apologize for any impact this may have had on your service. Don't hesitate to contact us by reaching PubNub Support (support@pubnub.com) if you wish to discuss the impact on your service.
Posted Apr 02, 2023 - 17:13 UTC
Monitoring
Around 16:30 UTC a fix has been implemented and we are monitoring the results for next 30 mins.
Posted Apr 02, 2023 - 16:39 UTC
Identified
Beginning at 15:34 UTC 04/02, some customers may be experiencing a higher rate of timeouts and errors in Presence, Push, HIstory, Subscribe, and Auth Services.
Posted Apr 02, 2023 - 16:19 UTC
This incident affected: Points of Presence (North America Points of Presence) and Realtime Network (Storage and Playback Service, Presence Service, Access Manager Service, Mobile Push Gateway).