Events and Actions Outage in US East PoP. Events are not Being Dispatched.
Incident Report for PubNub
Postmortem

Problem Description, Impact, and Resolution 

On Tuesday May 2, 2023 at 21:23 UTC, we observed that Events and Actions messages were not being processed on our US PoP or EU Central PoP.  Shortly after observing the issue, we redeployed a processing schema, and the issue was resolved on May 2, 2023 at 22:00 UTC.

Mitigation Steps and Recommended Future Preventative Measures 

To prevent a similar issue from occurring in the future, we added the needed monitoring to alert us when Events and Actions messages are not being processed properly so we can redeploy the processing schema as needed.

Posted May 05, 2023 - 19:57 UTC

Resolved
This service incident has been resolved since 22:00 UTC
Posted May 02, 2023 - 22:53 UTC
Monitoring
The Events and Actions service in US-East has been restored and any messages that would trigger actions have now been processed.
Posted May 02, 2023 - 22:18 UTC
Investigating
Events and Actions messages are not currently being dispatched for customers in our US-East PoP.
Posted May 02, 2023 - 22:01 UTC